Emoji delete bug

Hi all,
I am not sure if this happens with other keyboards but I found a bug when deleting emoji with backspace. It deletes an emoji but replaces it with this symbol: �����.
When I try to delete the very symbol, it reproduces it again by three.
If I try to delete this :slightly_smiling_face::slightly_smiling_face::slightly_smiling_face:
Backspace once produces :slightly_smiling_face::slightly_smiling_face:���
Twice :slightly_smiling_face::slightly_smiling_face:�����
Three times :slightly_smiling_face::slightly_smiling_face:�������
I cannot delete those unless I use another non-keyman keyboard.
The emoji are from default or other installed keyboards or WhatsApp embedded. My keyboard does not have emoji.

Anyone has an thought?
Thanks
Ibrahima

I had the same problem. It also happened once where I was certain I didn’t type an emoji, and I try to backspace, but it never gone, it keeping changing letters instead, and sometimes add more tofu characters, and I can’t replicate the bug since. I will keep an eye.

Thank @bennylin
:slightly_smiling_face::yum::joy:�����
As you can see, I am still having the issue. Are you using a Keyman keyboard with emoji? Or emoji from another keyboard?

Thanks

@bennylin Feel free to create a bug to track this behavior when you can repro the behavior.

@ibrahima Can you send the keyboard in question over?

It happened again (while not typing emoji), tried to repro couple seconds later, failed. same keyboard, same environment (WhatsApp)… very elusive bug…

Edit: wait… seems i can repro it…

Bug submitted

1 Like