Disable Windows Shortcuts for changing keyboards

This isn’t technically a Keyman question, but I thought this would be a good place to ask.

I had installed a keyboard in Keyman as a test for somebody else, but I don’t want to use it personally. I realize I could just delete/uninstall the keyboard, but would like a long-term solution too.

I have turned off Keyman, but they keyboard is still in the Input Methods system bar:


Somehow, I keep triggering some keyboard shortcut, it might be WIN + Shift + Space (I’m not sure) that changes to the last keyboard in that list. WIN + Space changes to the next keyboard in the list, from top to bottom, which makes me think somehow I’m adding the Shift key as well, to go in the reverse order. I found a number of references saying that WIN + Space going to the next keyboard, but no mention of how to actually disable that shortcut sequence.

I cannot find a way to disable that shortcut in Windows. I have tried in the “Text Services and Input Languages” window, including the Change Key Sequence button there.

Any suggestions where to change this? Perhaps it’s registry thing?



I figured I’d post the question above, and then answer it (as I had already found the answer)!

I asked ChatGPT, and it didn’t know. Then I asked Bard, and it basically gave me an answer.

The Keyboard Manager in Windows PowerToys allows you to remap shortcuts, or completely disable them.


Bingo! That worked.

Yet another helpful tip from our friends at AI-central.

I’ve seen some of our users in Southeast Asia have similar issues because their Windows 11 had assigned the ` key for switching keyboards. Good to know how to disable/change the setting!