Diacritics with Function Keys

I’m new to Keyman for Macbook. I don’t seem to be able to create diacritics with Function keys. All I ever get is the actions my Function keys would normally make.

I’m guessing you are having trouble using the function keys (i.e. Shift/Alt/RightAlt) on the keyboard you are having. If so, for Keyman to work well on macOS, you have to initially configure a few things. Go to this help page and ensure you’ve enabled Keyman in macOS system preferences.

Thanks, Makara. I followed the Help article and adjusted my Keyman privacy settings, but when I got to the last section, i.e., Documents and folders, Keyman didn’t appear in the list. I tried using my Function keys again (F1, F2, etc), in case what I’d done was sufficient, but they still only provide the same functions assiɡned in the reɡular keyboard.

You may have to restart your machine for the updates to take effect.

A few specific questions:

  1. What version of macOS are you using?
  2. What version of Keyman are you using?
  3. What is the name of the “Keyman” keyboard are you trying to use?
  4. Please give me an example of the keystroke that you attempt to type and its expected output together with the actual output.

The info above should help me to reproduce the behavior and then ultimately get it resolved.

Thanks.
FIrst, I’ve shut down several times, but it didn’t make any difference.
Keyman icon at the top of my MacBook says it’s v5.0.270
I’m using the IPATotal keyboard.
I’m on MacBook Air 2, with Monterey OS v.12.6

Keystroke for diacritic this time: I created [ɔ] successfully, then continued to hold the key down to enter the “raised” diacritic, i.e., this ̝ copied from the TypeIt online keyboard) using the F11 function key , which gave me the Volume on-off Speaker icon only, which is the actual function of the F11 key. It seems to happen no matter which diacritic I try to insert. I get only the actual of the function key used.

I hope this helps. Thank you for looking into this.
Phyllis

You may need to use Fn+F11 on a MacBook (it is also possible to change the defaults; read How to use the function keys on your Mac – Apple Support (AU) for details).

None of these suggestions has worked unfortunately. I’ll try uninstalling and re-installing.