Devanagari in Word doc

in word doc, devanagari will not type vowels in compound, eg मु–“mu” मुनि “ni”
I deleted keyman and reinstalled. It works fine in Pages and in email and clearly here :slight_smile:
any thoughts???

Hi Maria - welcome! Can you tell us which keyboard you are using? Also, are you on Windows, macOS, or Linux?

The version of Microsoft Word might also be relevant.

What font are you using? If you change to a different font does the text display correctly?

If you copy text that shows up correctly in Pages or an email and paste it into Word does it show the same problem?

HI Lorna- Devanagari Unicode{US} and I am on MacOS. I did nto have a problem before but recently purchased a new computer. It all migrated over and worked fine with the exceptiuon of Word doc. I reinstalled Keyman and keyboards and made sure that Word was up to date

Yes I though of that – so I checked that Word was up to date and it is. Any other way to check Word?

Font is Nirmala UI-- when I change font it does not make any difference. And yes, I can type in Pages and copy and past into doc and it will work-- just cannot tyoe directly into Word

Check the Language Preferences settings under Word Options to see if you can add Hindi or Nepali (or whichever language you want to use).

Devanagari Unicode{US} and I am on MacOS.

I don’t see that keyboard you mentioned in our Keyman keyboards repo so I have no way of testing it. Could you try this keyboard and see if it works better?

Thanks Lorna but I do nto have that as an option-- only Devanagari Unicode US or Devanagari USinter or Devanagari DE-- and changing to Hindi as a font does nothing.
It was working and simply stopped ???

OK- Deleted keyboards- “Heidelburg”-- uploaded one you suggested above- still will not type vowels in devanagari- example is the u in muni मुनि as it WILL do here and in Pages and in email - NOT in Word–tried changing fonts to Hindi- still did not work.

seems to be a problem with Word- which I checked for updates. all good

recently purchased new computer and transferred everything-- this is the only problem.
thanks for any help

Hi @Maria,

I have now had the opportunity to load up Word on my test Mac but have not been able to reproduce the issue as you describe. Can you verify the versions of software you have installed. I have the following:

macOS version: 10.15.6 (click , About This Mac to find the installed version)
Word version: 16.40 (20081000) (click Word, About Microsoft Word)
Keyman version: 13.0.101 (check input methods menu, Keyman, About; it may show only ‘13.0’; if you still have the installer, that also shows the full version.)

(@Lorna, FWIW, this keyboard is part of the Heidelberg Input System package.)

One question: on some machines, typing too rapidly can sometimes cause letters to be dropped. Does the situation change if you type slowly into Word?

HI Marc
I am on macOS version 10.15.6
word 16.41
keyman 13.0.101

and I installed libreoffice: 7.0.1.2

and the problem remains— vowels problem as described by original poster is the same
NO typing slowly does nothing it just remains blank

I’m sorry for the delayed response. I have not been able to find any reason so far why Keyman + Word on your computer are not cooperating. Would you be willing to setup a remote assistance session with me sometime this week? If so, send me a direct message on this forum (click on my name here and click the Message button) and we’ll setup a time.

Adding for reference: https://github.com/keymanapp/keyman/issues/3251 reports consistent symptoms. Attempting to find repro of issue on my mac.

I tried typing various Devanagari sequences in Word on my mac and haven’t encountered a problem.

If Maria is using Catalina, I am wondering if the Security/Privacy settings are causing this, if I remember back, most of my problems with character sequences not typing correctly in Word were related to Keyman not having the correct permissions.

We went through all the language and privacy settings in a remote support session. I am investigating other possible causes but it will take a little while as I am not at work next week.