Delete text inside cover in templates?

I’ve created templates for decodables in national languages with some “notes to the authors” on the inside cover pages. When we try to delete these notes for publishing, Bloom just puts them right back. I think this is because the books were made with bloompack templates. Any way around this for local authors so they can delete the notes?

I’m not sure this is the problem you’re dealing with, but recent versions of Bloom allow you to edit things that are normally locked-down in shell books. Open the toolbox (three-lines control in the top right), select the cog-wheel icon, and look for “Allow changes to this shellbook.”

Dear Lisa,
I’m sorry to hear that Bloom isn’t doing the right thing here. If my hunch is correct, then you’re right, the problem is that your notes are in the BloomPack version of book in a different language than the users have in their collection. There is a bug (a perhaps misguided feature) in Bloom at play here: Bloom thinks to itself “Hey look, this box is empty, and I have this text here from this other language, maybe they’ll want that, so I’ll copy it in in case it’s helpful”. The idea was that the user can leave that text, translated it, or remove it. However if they remove it, then the next time the book is opened, Bloom again thinks “Hey look, this box is empty, and I have this text here from this other language, maybe they’ll want that, so I’ll copy it in in case it’s helpful”.

We will follow up here with some instructions for working around this in the short term, as well as our progress in fixing the problem.

Thanks so much John! That would be very helpful!

@leasterbrooks
I apologize for the delay. You have two options:

  1. We have fixed this in the 3.9 beta release, which we think is quite safe to start using. You can get that from our downloads page.
  2. Or in previous versions, you can paste an invisible character that will cause Bloom to think the text block is not empty, so it will leave it alone:
  1. Select and Copy the following and paste it into Bloom: 1​​​2
  2. backspace to delete the ‘2’.
  3. left arrow to put the cursor to the left of th ‘1’
  4. press “DEL” key to delete the ‘1’
  5. What will be left is are a couple of invisible characters.

Quite a hassle, sorry! Hopefully you can start using 3.9 soon.

Thanks John! very helpful!