Default English language name added by Bloom

Is there a way to hide the default English language name that Bloom adds to the Cover and Title pages?
A translator wants only the Spanish and Language visible, not English.

Or is there a way to change the default data to Spanish and add the extra info required.
I’m assuming the default English language name is based on the language code.

I don’t think there’s a standard, UI way to do this. But you can take advantage of Bloom’s underlying HTML. Try putting these lines in a file called customBookStyles.css (in a book folder), or customCollectionStyles.css (in the collection folder):

.bloom-editable.Title-On-Title-Page-style.bloom-contentNational1 {display:none}

Just remember you’ve done this in case you ever want to reverse it!

Doesn’t the user just want to change the national language to Spanish? Or am I misunderstanding?

Andrew, yes, but this does not affect the default language name Bloom adds.

Thanks, John, but that is over my head :slight_smile: New to Bloom!

Is it possible to provide a screenshot of the issue? I don’t think we are understanding the problem rightly.

This is a jpeg of the Cover page (ignore the “off” image)
The translator does not want the English language name that Bloom adds on the bottom. She only wants what is above it … which we enter.
The language options in “settings” does not touch this.

Same thing gets added to the Title page.

Ok, got it now. Thanks.

So, Bloom doesn’t handle this from the UI.
There are two ways to do it I can think of.

  1. This is what we call a “hack”. : )
  • Copy the invisible characters between the "x"s: x ​ x.
  • In the language settings for the vernacular language, click change, then paste the characters into the display name for the language.
  • Note that this will cause the language name to “disappear” everywhere else in Bloom, too.


  1. Similar to John Thomson’s suggestion above, but paste this line instead:
    div[data-book="languagesOfBook"] {display:none}

My turn to ask for a screenshot :slight_smile:

Hmmm, I don’t seem to have that option available!?

My colleague suggested a better route.
I’ll email you the css file you can add to your collection folder. This forum wouldn’t let me attach it directly.

Once you have the customCollectionStyles.css file, you put it in
My Documents/Bloom/YourCollectionName.
You should find such a file there already. You can replace it with the one I send.

Ha, got it! And it worked.
Thanks so much!!
Happy people here :slight_smile:

Hi Andrew,
With the latest Bloom upgrade this .css file is no longer working.
We now have the English language name showing up again.
Any suggestions?
Need a new .css file?

Oooops, fixed.
Just reinstalled the same .css file and now it works fine.

Andrew, this morning the English language name is visible again.
Need a updated .css file?

I emailed you an updated one. Indeed, the underlying data did change slightly.

Thanks Andrew.
Will I need to replace all of then in each book or just in the My Documents/Bloom/YourCollectionName?

Should just be the collection.