Deep linking Custom URI Scheme not working

Hi together,

I enabled deep linking and tried to use the Custom URI Scheme. Unfortunatly, this feature did not work. When I use the URL Scheme it is working fine.

Did I make some mistake or is there a bug in the current version of RAB?

Thank you!


Have you tried on a few phones?

Yes, I tried on Huawei P smart 2019 and on Samsung Galaxy S7 (emulator). Both times the Custom URI Scheme did not work but the URL Scheme did. I am using Windows 11 for developing.

We just tested it on a Samsung Galaxy A72. It is not working either.

I tested with RAB 9.3 (latest version) and it worked for me on Oppo running Android 11.

It also worked on a Huawei running Android 9

Can you give your custom URL?

How are you testing it? I used Deep Link Tester app.

Also tested on Oppo Android 8 and it worked too.

I entered ‘learnjola://’ into the field Custom URI Scheme. So I tried to navigate to page 7 by connecting a word on page 1 to the link ‘learnjola://B001.7’. This does not seem to work. I did not use a specific testing app, just tried to implement it into one I am creating right now. I am using 9.2.4 and Windows 11 OS.

Deep linking is for coming in from outside not for internal links.

You can use [go to book 1 page 7](B001.7) that is converted to an internal hyper link.

It does not matter if your source is Word or SFM, it will work in either.

Thank you very much! It is working!