Conversion of text typed in SILDoulosIPA93 fonts to Charis SIL Unicode font

Hi Colleagues. I have a manuscript typed in SILDoulosIPA93 font, which I would like to convert to Charis SIL Unicode font. Some of the special symbols such as diacritics and IPA symbols in the manuscript are simply unreadable.

Does anyone have an idea of how to get this done with more convenience than find and replace, which doesn’t seem to be of much help to me?

Thank you.

What application was used to create the document and what kind of computer (Windows? Mac? etc) do you use?

Many thanks. The document was created with Microsoft office (Windows). I use Windows computer.

Then I believe the recommended approach is to use SIL Encoding Converters. The Basic Converters package contains an IPA93 to Unicode converter definition. Depending on your specific setup, you can use either the MS Word Data Conversion Macro (requires 32 bit version of Word) or the Bulk Word Document Converter tool.

bobh has identified the best way to tackle your challenge: using SIL Converters (also known as Encoding Converters). Of the two options he mentioned, I think that, even though you may have only one file to convert, using the Bulk Word Document Converter will be the easiest for this case. Here are some additional details that might help:

After installing SIL Converters, open Bulk Word Document Converter, use File, Open and specify the file you wish to convert. The program will scan the file and present you with a table. In the first column is an entry for each font used in the document. The second column has some example data. The third column allows you to “select a converter”. If you don’t, then the data will remain unchanged. If you do, then the program shows you example results with the converter applied (fourth column) and using a different font if you choose (fifth column).

You will likely only need to change the entry for the “SILDoulosIPA93” font (and leave all the rest unchanged). For that one, I think you’ll want the “SIL IPA93<>UNICODE” converter that should have been installed with SIL Converters. You’ll then need to specify a Unicode font in the fifth column (“Apply Font”) so that the converted text will display properly.

If you need more assistance, please write again.

Very many thanks, Bob and David, for you suggestions. I’ll try what you suggested and let you know the result. Thank you very much, once again.

Hi Bob and David. I’ve tried the solution you suggested. Two documents with SILDoulosIPA93 fonts have been converted. The IPA symbols were excellently converted, although I had to use “Find and replace” to deal with some of the letters with diacritics. Incidentally, there’s one document containing SILDoulosIPA93, SILDoulosIPA-Regular, and IPAKiel that is problematic to convert. Each time I tried to convert it, I received the following message:

"Unable to convert and/or save! Reason:

Word encountered an error processing the XML file tmp82A2.tmp
Unexpected end of input.

Location: Line 20512, Column: 15

If the conversion was already started when this error occurred, then you can’t click ‘Convert and Save’ again (to avoid converting the document twice).

Click ‘Yes’ to reload the files from scratch."

I clicked ‘Yes’ to reload the file from scratch but kept receiving the same message. Any ideas as to how to deal with this?

Thank you, once again.

Glad the tool is mostly working for you. I haven’t encountered this error before.

One possibility is to cut the original document in sections and convert each section until you isolate the error. If the problem text ends up being short, you could retype it in the new document.

Make sure you aren’t trying to convert the SILDoulosIPA-Regular nor the IPAKiel data using the SIL IPA93 converter. Those fonts had a different encoding. It’s possible that’s where the error is if you are trying to convert those.

I’ll have to research what the SILDoulosIPA-Regular font is. It’s possible that was a Unicode font.

We have not created a converter for the IPAKiel because I don’t think we had access to the font to see the encoding.

Many thanks, David. It’s a big document. Nevertheless, I’ll try the possibility you suggested.

Hi Lorna. Many thanks. I also suspect that the SILDoulosIPA-Regular and IPAKiel fonts in the document might be the cause of the error message I received, since the converter was able to convert the SILDoulosIPA93 fonts but not the SILDoulosIPA-Regular and IPAKiel ones. I think there may not be many instances of SILDoulosIPA-Regular and IPAKiel in the document but I simply can’t locate them in a rather large document. Any ideas as to how to locate these troublesome fonts in the document and change them manually?

You can search for any text in a specific font using the advanced search dialog. Modern versions of Word hide this in the dropdown in the Navigation pane:


Once you get to the Find & Replace dialog, leave the “Find what:” field empty and use the Format dropdown to select the font you want to look for:


In the Font dialog, type in or select the name of the font you want to find and click OK. Then click “Find next” and Word will look for any text in that font and select it for you.

Hope this helps,


Apologies that the images didn’t make it into that previous post on first attempt. You can now see them online by viewing the message on the web. (if you are viewing this message in your email client, click the View Topic button at the bottom).

Very many thanks, Bob. I followed your suggestions diligently. I found the texts in SILDoulosIPA-Regular and IPAKiel and replaced them with Times New Roman. But when I tried to concert the document to replace instances of SILDoulosIPA93 with Charis SIL using the Bulk Word Document Converter, I received the same error message. Here are three dialogue boxes that showed up (see the second and third dialogue boxes in separate post, since I can’t post all three as a new user). I don’t know if they could provide a clue to the solution:

In the second dialogue box, it didn’t make any difference whether I clicked 'Skip, ‘Replace’, or ‘Replace All’, the same error message in the third dialogue box showed up. I hope this problem is sorted out in the long run.

Thanks for the so much effort you, David and Lorna have put in thus far to try to address this seemingly annoying and persistent problem.

I’ve been looking at the two files with problems.

The file “Deg-Eng Dic A-Y Final.doc” seems to have two occurrences in the IPAKiel font. In each case it is the single character “]” (U+005D) and it appears as the final character in the string just before the italic “n” in the entries for “ukob?a1” and “ukob?a2”. I don’t see the IPAKiel font in the other document.

The conversion mapping is failing on three occurrences of “g” followed by 0xF2 which, in the SILDoulosIPA93 font corresponds to the Unicode combining tilde overlay character (U+0334). I don’t know if this sequence is intended or not, but I created a mapping that converts this sequence, but then the conversion failed with another problem.

I’m still investigating.