Conflict with Citrix?

I have a Windows-10 laptop. Today, I installed a Yiddish keyboard using: keymandesktop- It worked well in Microsoft Word switching between English and Yiddish.

Later, I access “work” using Citrex, but my English keyboard went awry. I tried to disable the keyboard entirely using the Hotkey combination Shift-Alt-O, but that didn’t help. I had to uninstall Keyman in order to log into Citrix.

Is this a known issue. Is there a way to disable the keyboard without uninstalling it?

Avi Pitt

To disable a keyboard on Keyman for Windows (aka Keyman Desktop), you can uncheck the keyboard you would like to disable from the Keyboard Layouts tab in the Keyman Configuration (see the screenshot below).

Here are the instructions: Keyboard Task - Enable and Disable a Keyboard.

I appreciate your quick reply. I disabled the only keyboard I installed (Yiddish Pasekh) as described, but that did not solve the problem. I still am unable to log into Citrix Workspace. I try to type my username:


But see:


I try again, and see:


Each time I try, I see something different. I rechecked Configuration to verify that the keyboard was still disabled, and it was. Apparently, there’s something I need to disable in addition to the keyboard. Any suggestions?

Avi Pitt

នៅថ្ងៃទី ចន្ទ 18 មករា 2021 នៅម៉ោង 11:07 PM Avi Pitt via SIL Software <> បានសរសេរ៖

You can exit Keyman by clicking on the Keyman icon in the notification area and selecting Exit.


There may be also another configuration change that you can make that improves compatibility with Citrix; read KB article 97 for more detail on disabling serialized input.

Thanks! Right-clicking on the Keyman icon in the Notification Tray and selecting Exit from the pop-up menu was all I needed. Now I can log into Citrix and use it with no problem.

1 Like