Compiling keyman 12

I am compiling keyman 12. I am getting below error.

I can see ‘lexical-model-types’ is linked to the keyman\common\lexical-model-types

But still the compiler is complaining about it.

npm ERR! code ENOENT
npm ERR! syscall open
npm ERR! path C:\Users\login\AppData\Roaming\npm\node_modules\@keymanapp\lexical-model-types\package.json
npm ERR! errno -4058
npm ERR! enoent ENOENT: no such file or directory, open 'C:\Users\login\AppData\Roaming\npm\node_modules\@keymanapp\lexical-model-types\package.json'
npm ERR! enoent This is related to npm not being able to find a file.
npm ERR! enoent

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\login\AppData\Roaming\npm-cache\_logs\2019-11-03T15_41_05_587Z-debug.log
Could not link lexical-model-types
Failed to compile the language modeling layer module.

Can you give a little more context on the build log – say the 20 lines before the error?



Okay, I’m not entirely sure what is causing the problem at this point. Can you check your npm and node versions are up to date?

Are you building from master?

image
image

I am building from Stable 12.0

I moved the source to c drive and run the vs as admin. It is moving forward.

I will keep you posted.

Thanks

I was successful in compiling

Under
\keyman\windows\src\global\wix\wixui

we have localized wix for german et al,

But the installation wizard doesn’t provide the options.

is it linked to system language or something?

1 Like

Keyman Desktop doesn’t use WixUI – it has a bootstrap application (setup.exe) then runs a silent install.

Keyman Developer still does, but localization is not linked in at this time.

Hopefully you don’t need to run as Admin? Which issue was it that solved the problem? If it is moving drives then it could be an NPM bug that should be reported.

W drive is network drive per Windows 10. I open the lexical model “Junction” linked to W: drive. I was not able to open it. Although it was linked. It is perhaps a security measure to not allow symbolic link windows. I didn’t explore the solution, instead moved the source to C drive. Problem solved.

1 Like