Closing brace not working

Hi everyone,

I have been using the IPA MSKCL to conveniently type IPA characters until now, but as I was configuring my new notebook, I saw that the use of the MSKCL was discouraged, or at least outdated, so I installed Keyman (Windows 10 Home).

It does take some getting used to, but it works fine. However, I cannot figure out why the closing brace will not work for me. Everything else seems to work fine, but primary and secondary stress (as well as fortis/weird-snakey lenis signs) are inaccessible somehow, observe:

I type: [h}e__nt}}e__], I want: [ˈhe̞nˌte̞], but I receive: [he̞nte̞]

I tried it across platforms and programmes (Facebook, Google, WordPad, Word, here). I have also gone through all other possible combinations, and everything seems to be in order, even the opening brace “{” is accessible and does what it is supposed to.

On a side note, hypothetically, how would I avoid typing a lenis when I wanted a primary stress + fortis? I mean, “}}}}” is lenis, but “}}}” is fortis and “}” is primary stress. So, if I had something like Korean [oˈp͈a], I would probably type: [op}}}}a], but that would render as [op᷂a]*, would it not? Is the Combining Grapheme Joiner indicated here, i.e. [op}=<}}}a]?

Thank you in advance, and I hope my question hasn’t been asked before (I couldn’t find much), or isn’t formulated too confusingly to understand.

*I have never seen that snakey-wiggle, by the way. What a peculiar little diacritic.

Welcome to the community @Polyglottery!

That’s curious. I just typed exactly what you did, with the most recent version of the SIL IPA keyboard: [h}e__nt}}e__] and I got [hˈe̞ntˌe̞], which is what you expected to get.

Can you give me some more detail on your setup?

  • Version of Keyman
  • Version of the IPA keyboard installed
  • Your base layout (in Keyman Options)

Alternatively, you could send us a private diagnostic report and reference this discussion – that will give us more technical details on why you may be experiencing an issue with that specific } key.

You’d type the primary stress before the p, and the fortis after, wouldn’t you? [o}p}}}a] gives me [oˈp͈a].

Hi, sure!

  • My version of Keyman is 14.0.273
  • IPA Keyboard version is 1.8.4 (mnemonic)
  • Base layout is German (Germany)

Thanks for the additional detail. When I tried to reproduce the issue when using a German base layout, I was able to see the problem that you described. I have written up a bug report at [sil_ipa] bug: with German base keyboard cannot type `}` · Issue #1532 · keymanapp/keyboards · GitHub and hopefully we’ll be able to issue an updated version of the sil_ipa keyboard shortly.