CHANDRABINDU not working in itrans (m17n) keyboard

I’ve installed Keyman Devanagari itrans m17n keyboard on ubuntu 22.04 and it is working well apart from CHANDRABINDU. The documentation says “<” should produce this symbol [SHIFT ,] but in my case it just produces <.
Elsewhere in the documentation it seems MM should do it, but that just produces a double anusvara.

I’ve noticed other discrepancies (comma for me produces a comma, while the documentation says it should produce a devanagari abbreviation sign, and you need two commas to get a comma).
Anybody else have this issue, or suggestions on how to solve it?

Welcome to the community @Jon,

I tried finding the keyboard from the Keyman’s keyboard list using Windows 10 but unable to find a perfect match. Could you help look in this link?

If the three examples mentioned above are still not producible then we hope you don’t mind trying another keyboard (Hindi Devanagari Phonetic (ITRANS) keyboard) that uses:

  • M + M = (CHANDRABINDU)
  • , + , = (devanagari abbreviation sign)
  • M = anusvāra

Download keyboard.

Apart from the three examples above, does the keyboard output correctly on other keys?

Please also provide the documentation that you referred to. Thank you!

Many thanks for your quick response.

I think the keyboard I have installed is the one you suggest (Hindi Devanagari Phonetic (ITRANS) keyboard)

The documentation here
https://help.keyman.com/keyboard/itrans_devanagari_hindi/1.2.1/itrans_devanagari_hindi

seems to more-or-less match what happens for me, apart from the fact that MM produces just a (slightly bolder) anusvara rather than chandrabindu:

kM = कं

kMM = कंं

Also the , combination does not work.

, = ,

Thank you for quickly responding to this, @Jon.

I’m glad that the keyboard we are referring to is the same. It’s really strange how the same keyboard uses different key combinations to produce the same output, it would be much helpful if you could add a video of this behavior to Google Drive.

This is what I can reproduce:

kM = क्ं
kMM = क्ँ

It is possible that different fonts show slightly different outputs. Could you send a screenshot of Keyman Configuration windows of the keyboard:

A comma alone will output as you described but when 2 commas combined, it will output .


Instead of having to use the key combinations you previously described, the documentation described totally different ways of producing the three letters you want, which also answer the question to why < is not .

You are welcome to provide the screenshots to showcase the difference of:

If you have any further question, feel free to ask.

Hmm, I replied using email rather than web browser and not all my message is shown and some is corrupted. Strange. Replying now using a web browser.

My original reply said:
Also the , combination does not work. [not sure why that came out as a single ,]

, = ,

… = । works, but … = ।., – = – and — = — do not.

The zero width non joiner and joiner don’t seem to work.
a_i produces अ_इ

k+S produces क+ष

The non joiner not working is a bit of a pain, because to produce अइ rather than ऐ requires adding in _ and then deleting.

Various other things don’t quite work, but are not an issue for me.

I’m on Ubuntu 22.04 so not sure whether I have an equivalent to your Keyman Configuration window. Here is all I have
Screenshot from 2024-04-30 09-20-47

1 Like

Weird that the comma came out as a single comma again. I’m typing double commas and I see double commas until I post

, = ,

Also I see that the other key combinations I found were from the 1.0.0 version of the documentation. Sorry for that red herring.

Thank you for getting back so soon @Jon.

I’m glad it was related to the keyboard documentation version.

Does typing comma twice work on other applications? Could you please report back on which keys that are still responding incorrectly from the keyboard documentation version 1.2.1?

Look forward to hearing back from you.

Hi Mengheng,
Sorry for the slow reply.
So looking through the help documentation that was installed with the keyboard, the following is a list of things that are different:

Default (unshifted)
q gives क़ [makes sense - I prefer this]
[ gives [
] gives ]
\ gives
f gives फ़ [makes sense - I prefer this]
z gives ज़ [makes sense - I prefer this]

Shift
3 gives #
4 gives र्
5 gives %
6 gives ^
7 gives &
8 gives *
Q gives Q
W gives W
E gives ऎ
R gives ऋ
Y gives य़
O gives ऒ
P gives P
[ gives {
] gives }
F gives F
Z gives Z
X gives X
V gives V
B gives B

AltGR (unshifted)
123456789 give numbers

Vowels and vowel signs
@ gives "
" gives @

LL^ gives LL^

Conjuncts
k^S produces क^ष
a_i produces अ_इ

Zero Width Joiner
k+S produces क+ष

Punctuation
, , produces , ,
… produces ।।
dashes just produce dashes

The only things that bother me are candrabindu MM and the Zero Width Non Joiner _

Hi @Jon,

I hope you are doing well. I will need some time to get my Ubuntu working and it is odd that some keys are not responding as they should be.

Thank you for being patience.

Hello @Jon,

My test result come out the same as tested on Windows 10 (starting with letter q to m
and other keys on the keyboard):


The keyboard package I have:

The Ubuntu configuration:


It seems that the keyboard on your Ubuntu is still on version 1.0 but that doesn’t explain why some keys do not respond accordingly. How long have you been using this keyboard and until when did you notice the changes? How did you install Keyman?

Have you tried reinstalling the keyboard? If that didn’t work, then could you please walk me through the process of setting up Ubuntu on your Windows? This might require a reinstallation of Keyman, would you be able to try all of the deletion method?

Hello @MengHeng

I reinstalled keyman and the keyboard and got the same behaviour.

I am on Ubuntu 22.04.04 LTS
GNOME Version 42.9
Windowing System X11

I think it is to do with the window manager.
I am using GNOME Flashback (Metacity).

If I switch to MATE then I get different behaviour.

I also use X11 rather than Wayland, but switching to Wayland made no difference.

Best wishes,

Jon

Hello @Jon,

Can you tell me:

  1. Which Keyman version do you have?
  2. Could you tell me which applications produce the behavior mentioned?