Can't update the LIFT file in DAB

Whenever I make an app in DAB and try to update the LIFT file in the tab “Lexicon” the new app no longer works. So whenever there is a slight change in my FLEx database and I want to make a new version of the app, I need to start from zero and create a whole new app, re-inputting all the details and settings. Am I doing something wrong that I can’t update the LIFT file?
Thanks for any help you can give!

What is your DAB and FLEx version? Are you on Windows or Mac?

Sorry! I’m on Windows. I have FLEx and I just updated to DAB 9.2.1 recently to see if that would work better, but it still didn’t solve the issue.

It would be good to update to the latest DAB, version 9.2.3, but I’m pretty sure that won’t fix this problem.

I don’t know where you put the new LIFT file, but when I exported an updated LIFT file from FLEx to exactly the same directory as before, and then clicked on the Update From Source… button:
I was able to build an updated version of my app successfully.

Were you trying to use the Update From Other Source button…? My gut feel is that that might not work as well. So can you try exporting your LIFT file to exactly the same folder (if that’s not what you were doing), update from source and try to build? Although just now I also tried Update From Other Source…, and that also worked for me.

If you continue to have the problem, it might be good to send me the LIFT folders (before and after your update), and let me try to build on my end. I probably won’t be able to get to it quickly, but that may help us track down the problem.


Hi Jeff,

Thanks for your help! I updated to the latest DAB and also put the new LIFT file in exactly the same directory as before and clicked on “Update from Source,” and it worked! I still have a few kinks to work out, but knowing that I can just make a few minor changes and try it again to see how it works is much more encouraging than having to start from scratch each time. So thank you!


1 Like

That’s great news! So glad that worked for you. Do you by chance remember what was different that you did before that didn’t work? If it is something that is repeatable, we may be able to track down and fix the problem…

I don’t honestly remember. I think I probably clicked the button “Update from another source,” but I can’t remember exactly. Sorry!