Can't search for emojis or GIFs in the Windows Emoji Panel if Keyman is running

In Windows 10 & 11, you can bring up an emoji and GIF search modal window (the Windows Emoji Panel) by typing the Windows key and the plus sign (+). It allows you to find and insert an emoji or a GIF in pretty much any application that you can type in: Word, PowerPoint, Gmail, Notepad, the Keyman Community Forum, etc.

There’s a search box at the top of panel where you can type keywords to find an appropriate emoji or GIF: bird, bus, sad, LOL, etc.

If the Keyman app is running, you can’t type anything in the search box. All you can do is click on one of the emojis that you recently used to insert it in your document. You can’t search for a new one. Click, click, click, type, type, type. Nada.

It doesn’t matter what language keyboard is currently selected in Keyman. US English, French, Yiddish - none of them work. The language choice is not a factor in this specific issue.

Exit the Keyman app, the emoji panel works normally. Launch Keyman again, the emoji panel search stops working again. Wax on, wax off. The presence of the Keyman app is the one and only cause of not being able to type in the emoji panel search box.

Has anyone else noticed this? Any workarounds? In the spectrum of problems, I rate this as an annoyance, not a showstopper, but I’d love to get it resolved.

BTW I have no issue flipping to US English when I want to find and add an emoji to my Yiddish document, and then hot key back to Yiddish to continue writing. Perfectly reasonable. I have no expectation that the Windows emoji panel search could find anything in languages other than English.

Thanks.

1 Like

I open that panel with the Windows key plus the “.” key. I am able to search just fine, although what I type simply appears wherever I was already typing. Once I select an emoji, it replaces the typed text with an emoji.

I am running Windows 10 Pro (up-to-date) and a Keyman keyboard that I built about a year ago.

I can provide more details if needed.

I hope this helps.

1 Like

@DrJay, which version of Keyman are you using?

My OS: Windows 11, Version 21H2, OS Build 22000.346 (up to date as of this writing)

I’m on the latest GA version of Keyman for Windows: 14.0.283

Installed keyboards:
EuroLatin (SIL), Latin American Basic, and Yiddish Pasekh. I flip between them with hotkeys.

My options/settings:

Does anything look off?

Thanks very much.

I can confirm I’m also having this issue. I’m on Windows 11 OS Build 22000.348, and using Keyman 14.0.282. I have the SIL IPA keyboard installed and no others. All Keyman hotkeys are turned off.

Thank you @Daniel_Hieber for confirming this – and welcome :slight_smile:

I have now also replicated this on a Windows 11 virtual machine here. I also have a workaround: disable Keyman’s serialized input:

  1. Open Keyman Configuration

  2. Select Options / Keyman System Settings

  3. For engine.compatibility.serialize_input, enter the value 0.

  4. Click Apply, Close, and then restart Keyman

Note that this setting change is not necessarily ideal, as it may make rapid input with Keyman slightly less reliable. We have a horribly technical and detailed blog post about it: https://blog.keyman.com/2018/10/the-keyman-keyboard-input-pipeline/

I have opened issue #5996 to track this.

Yeah, I was gonna suggest disabling that cerealizer input :bowl_with_spoon: setting. Or calibrating the warp drive and limiting the output of the photon torpedoes. :joy:

Thank you, Marc! I’ll give it a try and report back here.

1 Like

Changing that parameter to 0 fixed the issue. Thanks very much @Marc. :+1:

1 Like

This was the next thing I was going to suggest, but the instructions are pretty technical.

@DrJay There has been a fix to allow keyboard input when searching for emojis when Keyman is running. As you stated the search will probably work better switching between Yiddish and US English with hotkeys.
The fix is in the 15.0 beta versions. Keyman version 15.0.230-beta so 15.0.230 or greater.

1 Like

Thank you for following up with this info, @ross. Win11 has been a wild ride so far. So kudos to the person who found and fixed the defect.