Build Failed

My Internet connect is good.
I had tried by changing signing key but the problem can’t be solved. It always said like this:

*** JDK ***

java version “1.8.0_121”
Java™ SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot™ 64-Bit Server VM (build 25.121-b13, mixed mode)

*** Android SDK ***

Target Android Platform: Android 10 (API 29)
Minimum Android Platform: Android 5.0 Lollipop (API 21)
SDK Tools Version: cmdline-tools 4.0
SDK Build Tools Version: 29.0.3
SDK Platform Tools Version: 31.0.2

*** Compiling Android APK ***

C:\temp\SIL\build\RAB.001\a>call gradle clean assembleRelease --warning-mode=none

FAILURE: Build failed with an exception.

  • Where:
    Build file ‘C:\temp\SIL\build\RAB.001\a\build.gradle’ line: 91

  • What went wrong:
    A problem occurred evaluating root project ‘a’.

No such property: signingConfigs for class: java.lang.String

  • Try:
    Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 5s
The system cannot find the path specified.

BUILD FAILED:
The signed apk was not built successfully. This could be due to an internet connection problem. On the first build, the compiler needs to connect to the internet to download some library files.

A couple of things I noticed but not related to the failure.

You still have an Oracle Java JDK installed. If you have a paid license then you can use that but if not we recommend Azule Java JDK, so as ot to breach the license currently on the Oracle Java JDK.

Your SDK Build Tools Version should be 30. You may want to run Install Packages to update it.

Do you have a separate Gradle installation on your computer?

What are the two settings on the Tools > Settings > Build Folders tab?

Thank you so much.
You solved my problems. Now I can build apps successfully.

Good to hear it is now fixed.