Bug with left-alt

Hi all,

I’m currently using the latest stable release of Keyman on Windows 10 and running into a very frustrating bug. I don’t know what causes it, but at some point Keyman sort of takes over my left alt as if it’s permanently sticky. At that point I can no longer can use shift with certain letters, without Keyman taking over and popping up the keyboard or menu, such as with K and O. It does not seem to matter what program I am running when this happens… I had to in fact completely quite Keyman just to type this message, as it uses so many capital K’s!

Is this a bug or an intended feature? If it’s an intended feature, how do I disable it? I do have all sticky keys disabled in Windows.

If it’s a bug, is it fixed in version 15 or 16? I’m willing to install a beta version to get this fixed, as right now whatever this behavior is is very frustrating.

Thanks!

I thought most of these issues had been resolved in the newer versions of Keyman. You could try going into Keyman Configuration and then go into the “Hotkeys” tab and change the hotkeys for SHIFT+ALT+ K, M, or O.

It’s possible! Do you know what version exactly they were fixed in? As I said, there are a LOT of versions past what I am currently using :smiley:

I believe this is probably the same issue as described in Problems with Keyman windows popping up. We wrote a fix for it in #5189 but found some compatibility issues, so the fix is currently disabled by default in 14.0 (it will be enabled in 15.0). You can turn the fix on with the following steps, for Keyman 14.0.275 or later:

  1. Open Keyman Configuration
  2. Select Options tab, scroll to the bottom and click Keyman System Settings
  3. Accept the elevation prompt. The Keyman Settings Manager will open.
  4. Find the setting named engine.compatibility.old_cached_hotkey_modifier_state and set the value to 0:
  5. Click Apply to save changes, then click Close to close the dialog.
  6. Exit and restart Keyman (these system flags do not necessarily take effect until a Keyman restart).

Please let us know how this goes for you!

Note: Keyman 15.0.222-beta or later has a fix for that compatibility problem noted above that we have not yet ported back to 14.0. As it is still beta software, there may still be other issues! (We are now working to port this fix back to 14.0.)

We’ve just released build 14.0.291 which I am hopeful addresses the compatibility issue I referenced, so if you switch that engine.compatibility.old_cached_hotkey_modifier_state value to 0 as described above, that should fix the issue. Please do let us know how you go!