Best browser with Keyman Yiddish Pasekh keyboard

I’ve installed Keyman Yiddish Pasekh keyboard on my Windows 10 laptop, and it works very well with Word. I can’t use it directly when searching with Chrome. I have to type in Word and copy and paste to the browser. Do you know of certain browsers that work well with the keyboard?

Can you give us the following info:

  1. What is your Chrome version?
  2. What is your Keyman version?
  3. Can you confirm if this is the keyboard you are having this issue with, Yiddish Pasekh keyboard?
  4. Can you give me a few example words or character sequences together with their actual output and expected output?

These would help us to test and reproduce the issue.

  1. Google Chrome Version 88.0.4324.104 (Official Build) (64-bit)

  2. Keyman Desktop 10.0

  3. The options I see when I click on Keyman in the tray are:

EN English (United States) - US

YI Yiddish (Hebrew) - Standard

YD Eastern Yiddish (ydd - Hebr)

Hebrew (Standard)

Yiddish Pesakh

I select the last item in the list.

  1. Keyboard characters:

fiw, gut-morgn, bobe

result in Word

פֿיש, גוט־מאָרגן, באָבע

result in google or gmail (including commas)

What is the expected output of each of these?
What is the actual output of each of these if you type directly in Chrome?

Are you aware and follow this document Yiddish Pasekh Keyboard Help?

Were you not able to read it in my last email?

Keyboard characters: fiw, gut-morgn, bobe
expected result in Word: פֿיש, גוט־מאָרגן, באָבע

incorrect result in Google or Gmail (including commas): כֿן’ת עוא-צםָרעשַמת נםָנק

Avi

The incorrect sequence was missing from your last email.

Is this incorrect result happening only in Gmail or Google? Is it possible you have the Google Input Tools enabled on those sites? Or could you have a Chrome extension which is conflicting?

For example, can you try visiting bing.com and testing the same sequence there?

The keyboard works as expected:

Tested with Keyman 10 v10.0.1208.0:

  • Gmail on Chrome v88.0.4324.104 (Official Build) (64-bit)
  • Gmail on Microsoft Edge 88.0.705.50 (Official build) (64-bit)
    image
  • Google omnibox:
    image

Here is the text typed (of key sequences: fiw, gut-morgn, bobe) using the keyboard directly in this box on Chrome:

פֿיש, גוט־מאָרגן, באָבע

Please check again and see if the keyboard in question is indeed in use when you are on Gmail or Google.

You were right that the problem seems to be specifically with Google Chrome. I was able to type Yiddish accurately when using Microsoft Edge.

I’d really like to be able to use Yiddish with Chrome. I removed all extensions except for my Malwarebytes Browser Guard, which I temporarily disabled. I also noted that Developer Mode was turned off. I then shut down my laptop. After booting up, I again tried to type fiw in Yiddish but got כֿן’.

You mentioned input tools, but isn’t that an extension? Do you have any other suggestions of what else I might try in Google? A setting change?

I really appreciate your taking the time to answer my questions.

Avi

I tried uninstalling Google and reinstalling it. I opened it without signing in or customizing it in any way. Still, when I type “fiw” with the Yiddish keyboard, I get כֿן’

In addition to displaying the wrong letters, the final letter I typed was placed to the right of the other letters. I thought for sure that uninstalling and reinstalling would work. Now I’m really stumped why it would work for you in the same browser and not for me.

Avi

I stated the wrong Keyman/Yiddish Pasekh versions earlier. According to the installer, the versions are: keymandesktop-13.0.115.0-yiddish_pasekh-1.8.exe. However, when I look at Help/About, the version stated is Keyman 10.

I tried once more to fix the issue by uninstalling. This time, I uninstalled both Google Chrome and Keyman. I shut down my laptop and rebooted. I then reinstalled first Google Chrome (without signing in) and then Keyman/Yiddish Pasekh. I still have the problem typing in Chrome and Gmail.

Avi

It is obvious that the keyboard enabled when you are on Chrome is not Keyman version of Yiddish Pasekh. Since the keyboard does work as expected for you on Microsoft Edge, it means that something is wrong with your input tool on Chrome.

  1. Can you confirm that the keyboard icon image stays when you are typing on Chrome? If it doesn’t stay so on the taskbar while typing, the keyboard is not at all in use at that instance.

  2. You might have Google Input Tool enabled in your Chrome browser.
    Here are the output when typing with Google input tool and Keyman Desktop 10:

Yes, the icon you copied in your email continues to display in the task bar while I type in Google.

I thought Google input tools was an add-on or an extension. I don’t have any such add-in or extension.

Avi

It is a Chrome extension. The screenshot above is there to show the differences. This behavior is very weird, if you’d like we have a live support via Skype or Zoom.