Base keyboard confusion

I have a computer recently arrived from the USA with an English - US physical keyboard. The UI of Windows has been changed to French, and I think that means that the default system keyboard is French. Keyman is installed with the Tchad keyboard (latest version 4.2). Since the user is not used to the French keyboard layout (AZERTY), when the Tchad keyboard is activated, I would like the keys on the US keyboard to be the keys that are actully typed, NOT the French layout. I thought that was a simple matter of changing the base keyboard (Config > Options > Advanced > Base Keyboard) to English - US. After I do that, I check by typing qwerty, but the keyboard still outputs azerty.

Where do I go to fix this problem? (Note, the Tchad keyboard is mneomonic.)

Thanks,
Jeff

I’m not sure what the cause of this issue is – something sounds awry somewhere. Can you organise a diagnostic report for the computer (See KMKB0040 for instructions)?

I noticed that they were running 14.0.286, but that there was a version 14.0.290, so I updated them to the newer version, and that seemed to kick off whatever needed to happen to make it work right again. So I think we are good for now.

1 Like

Interesting – there are no changes between those two versions which should have impacted that, but glad the problem is resolved anyway!

Hi, I am new here. So I’m not sure, if I get it all.
When you uses different languages and keyboards on your Windows computer, you have to clarify 2 things: Which is the favored and set language AND: Which ist the set keyboard. Example: I uses German as main language, but change some times the keyboard. You can mix this. There are shortcuts pre-defined to change the keyboard. So sometimes my keyboard writes Chinese characters. In the task line (systray) you normaly can see and check, which keyboard currently is set.

I think your default keyboard should be the one that is ready to use right after the machine started. If you would like to know what base keyboard you are using in Keyman, you can check in the Configuration… > Options tab > scroll to the bottom and click on “Base keyboard…”. You can change this to German if it’s not so for you yet.

i.e., I have “English - US” as my Base keyboard.