Automatic addition of shtumer alef when typing a Yiddish word that begins with the vuv-yud ("oy") diphthong

#1

Yiddish words that begin with a vowel need a shtumer alef as the first letter before the vowel, as in the word אױפֿן.

When I type words that begin with other vowels, (e.g. אין), I get a shtumer alef prepended automatically, every time. But when I type a capital O (letter oh) to get the vuv-yed diphthong, the shtumer alef doesn’t appear automatically. When I typed the example above, I had to to begin the word with a manual entry of the alef (keyboard Capital-A) before typing the capital O.

Am I entering the vuv-yud diphthong incorrectly and this is a user error/works as designed? Or is there a bug in the logic of the Yiddish Pasekh keyboard?

Thanks very much.

Jay

0 Likes

#2

I don’t know Yiddish, but did you follow the instructions here:

Shtumer Alef is automatically inserted before ay, ey, i, oy, or u at the beginning of words. You can type a word-internal shtumer alef with Shift T+A

To get this אױפֿו , type “oyfu”.

For more on how to type Yiddhish, please refer to this: https://help.keyman.com/keyboard/yiddish_pasekh/1.8/yiddish_pasekh.php

Let us know if there is anything to improve there.

Thanks,
Makara

1 Like

#3

makara, your reply solved the mystery.

I was using the other method for entering a vuv-yud diphthong, i.e. Shift-O, rather than typing its transliteration as an o followed by a y . The latter gives me the prepended alef, the former does not. I didn’t realize that there was another method, the “oy,” to enter the אױ.

Problem solved. Thank you very much.

2 Likes