Audio streaming does not work, missing INTERNET permission in mainfest

Hi there.

I am using DAB 10.0.1 and want to add audio files to the dictionary. The files should be streamed from a remote location. I added a test file to “Audio → Audio files” and the target URL to “Audio → File Source”.

When I click the speaker button on the entry, no sound is played. In the webserver logs, I also see no request for this file. When I connect with adb to logcat, I see the error “Unexpected SecurityException: Permission denied (missing INTERNET permission?)”

As a test, I decompiled the apk, added the permission “android.permission.INTERNET” to the manifest file, recompiled (and signed) the app and tried again. Now it works, the sound is played when I push the button, logcat shows no more errors and I can see the request in the server log.

I don’t see a way to add this permission in DAB. I guess this is something that has to be fixed in DAB?



Update: I see that enabling analytics adds the INTERNET permission, so it seems to be buried in DAB somewhere already.

Can you show me an image of the the file source you set up? If that is setup correctly then that should trigger the Internet setting.

If you don’t want to share that publicly then send me a personal message.