Amharic Keyboard wont function fully on macOS Mojave

Greetings,

I installed a Keyman GFF Amharic Keyboard on my computer which has a macOS Mojave 10.14.5 operating system. Some of the combination keys on the keyboard don’t work properly. I deinstalled and reinstalled the keyboard again and again but with no change. Here is an example from my sample writing: ህa ህu ህi ህa ህie ህ ህo (the correct outcome should look this, ሀሁሂሃሄህሆ).
another example, ስeልaም => the correct one should look (ሰላም)

Please let me know, if there is anything I can do to solve the issue. Thank you for your time and expertise to help me solve the issue.

Hi Anbassa,

Thank you for reporting this issue.

Could you please give us the key sequences of these ህa ህu ህi ህa ህie ህ ህo and their corresponding expected output. That would help us figure out the problem and solution.

Best,
Makara

Dear Makara,

Thank you for your reply. the key sequences of these => ህa ህu ህi ህa ህie ህ ህo

The following is what I get when I type on the Keyman keyboard.

he => ህe

hu => ህu

hi => ህi

ha => ህa

hie => ህie

h => ህ (this one is correct)

ho => ህo

Their corresponding expected output should look like this

he => ሀ

hu => ሁ

hi => ሂ

ha => ሃ

hie => ሄ

h => ህ

ho => ሆ

Any character combination typed to create the right Amharic sound wont bring the expected outcome. By the way, my friend has the same keyboard installed on macOS Sierra operating system and the Keyman Amharic keyboard works fine there. The only issue I think is on the lates version of mac OS Mojave version 10.14.5.

Thank you for your help. And, please let me know if you require more information.

Thank you,

Anbassa

Hi Anbassa,

I don’t have Mojave to test this, but it works fine on High Sierra. It could potentially the OS that causes this issue. I will try to get Mojave up and test it again. In the mean times, our team are mostly away, so please expect a bit of a delay in getting back to you on this.

Thank you for your understanding,
Makara

Hi Anbassa,

I can get back to you quicker than I thought. We have tested GFF Amharic on Mojave and it works fine for us. We are wondering whether this issue is specific to any app that you are using the keyboard with. What app/program are you using when you encounter this issue?

Best,
Makara

Hi Makara,

Thank you so much for your help to solve the problem. The GFF Amharic keyboard doesn’t work properly on the programs that I use. I tried it on Microsoft Word, and Powerpoint, also tried it on Adobe InDesign, Photoshop and Illustrator but typing the keys “e, u, i, a, ie, o” on the keyboard wont generate the correct sound. I upgraded to the macOS Mojave last week and then all the apps on the computer work properly except the GFF Amharic Keyboard.

I found that the Keyman Amharic keyboard is very easy to use and the best Amharic keyboard setup I have seen so far. You guys deserve all the appreciation, and more!

I will keep trying to reinstall the keyboard. I hope it will work for me.

Best regards,

Anbassa

Hi Anbassa,

You are welcome. All credits go to the developer team and the keyboard owner. :slight_smile:

That’s weird. It works fine for my colleague on Mojave. And it works like a charm for me on High Sierra.

Hope the re-installation helps. Please keep us posted.

Best,
Makara

Hi Anbassa,
Can you tell us what version of Keyman (not the keyboard, but the program) you are running?
Lorna

Thank you Makara and Lorna for your help.

I used Keyman for macOS 11.0.220 which was released in February 2019. I even tried to reinstall it today but still having the same issues.

Best regards,

Anbassa

Okay, you are on the latest version (or close enough – there is one update that won’t impact this issue); we’ll dig a bit deeper here and see if we can pickup anything further.

Thank you so much. Greatly appreciate your help.

Hi Marc,

Today, I took my computer to the technology support specialist. They checked for the problem and tried to fix it, unfortunately, they couldn’t be able to identify the issue on the keyboard. I hope the issue will be addressed when the next version of the update is available. I look forward to it.

Thank you!

Hi Anbassa,

I have set up a virtual machine to test this, and it work fine for me. I can type the aforementioned key combinations with ease, and all give the expected output.

The keyboard I tested and it works: https://keyman.com/keyboards/gff_amharic .
The macOS I used to test: macOS Mojave Version 10.14.4 (18E226)
The Keyman version running for this test: Keyman Version 11.0.220

I am not sure what is happening on your end, but it seems like nothing is going wrong with Keyman on Mojave for us.

Best,
Makara

Note that @anbassa was experiencing this problem only on 10.14.5. So we need to test on that version further:

I have 10.14.5 on my computer, but I do not have Word, Powerpoint, InDesign, Photoshop or Illustrator, so I am unable to test those scenarios. @anbassa, can you tell me if the keyboard works correctly in TextEdit? I am trying to narrow down the specific environment in which it fails.

Dear Makara and the team,

Thank you so much for taking your precious time to address this issue.

The keyboard works correctly in TextEdit and Microsoft Powerpoint. On the other hand, it still is not functioning properly in the other programs such as Microsoft Word and all Adobe products (Illustrator, Photoshop, InDesign, After Effects).

I greatly appreciate your support and your responses.

Thank you,

Anbassa

I have now reproduced the problem in Microsoft Word. I have documented the problem at https://github.com/keymanapp/keyman/issues/1877 and we will be working on a resolution from there.

See also a similar report at SIL IPA ver 1.7 not functioning correctly on macOS Mojave.