After installing Keyman for macOS, Keyman is unavailable (grayed out)

Continuing the discussion from After installing Keyman for macOS, Keyman is unavailable (grayed out):

We have hit this problem helping an SIL member. Details requested:

  1. macBook Air (new summer 2018)
  2. High Sierra 10.13.6
  3. 10.0.111(1)
  4. No keyboard installed - we want to install a bespoke keyboard for testing
  5. Direct from keyman.com
  6. New
  7. Tried changing the file date in case the graying out was caused by the “Easter Egg” problem. No effect - read-only file. Have followed all the installation instructions precisely, and did two restarts.

Follow up to previous post: we have tried the method of copying problem file and renaming the copy, followed by deleting the original file, waiting for a few minutes, then renaming the copy back to the original name. This works for some users, but not in our case.

Next we shall try the standard unlocking procedure in the Terminal. If this fails we very much hope another Forum user has the answer.

At this point, I’ll wait for your attempt follow the standard unlocking procedure (although I’m not entirely sure what you are referring to; I’m also puzzled by your reference to the ‘Easter Egg’ problem?)

If that doesn’t work, we can look into alternative solutions.

Easter Egg problem: Apparently Steve Jobs presented his first Apple machine to the world on 24 April 1984, calling it an ‘Easter Egg’. For reasons I’ve not discovered the greyed out file problem can sometimes be fixed by changing the file date to one prior to said 1984 date.

Renaming a copy didn’t work. The “unlock procedure” went like this:

  1. Navigate your way to your Downloads folder.
  2. Find the file that is greyed out.
  3. Make a copy with a new name. Example: chess.dmg when copied would be chess_new.dmg
  4. Delete the original file.
  5. Wait at least five minutes.
  6. Change the name of the copy back to the name of the original file. Example: chess_new.dmg becomes chess.dmg
  7. Now try the installation method again.
  8. When you look at the Setting > Language section and (was it?) Input, is the Keyman file grey or black?
  9. If it is black you should be able to install the Ngbaka keyboard.
  10. If it is still grey repeat steps 1-5 but this time wait ten minutes.

This method failed. Then we tried this but it will not let the translation consultant key her password:

  1. Find the troublesome Keyman file in Finder.

  2. Open the Terminal.

  3. Type the following command, followed by a single space (do not press Enter yet).
    sudo chflags nouchg

    1. Drag the Keyman file from the Finder to the Terminal window. This will add the full path to the folder for the file.

    2. Press Enter to run the command, supplying your password when prompted.

So we are stuck. As a Windows user it is tricky trying to help a Mac user with this. Is the security chip in the latest macOS kit objecting to a digital signature? (Now grasping at straws.)

FWIW, I am not sure I can recommend any of the above procedures for addressing issues getting Keyman running.

I completed a remote support session just now and Keyman was working correctly when I observed it. So we are waiting now to see if the problem recurs.

That is really strange: macOS refused to recognise Keyman when the user was at my side. Now she reports that Keyman is working and that our keyboard has installed and runs OK.

I’m having this same issue and it still won’t work after multiple restarts. Has a bug fix been created?

@Rich_Meister, would you be willing to work with our macOS developer to investigate further? We have not yet found a resolution to the issue.

Yes. I can volunteer to work with the Devs on this.

Hi Rich

You can coordinate with @rfaramir - he’s in the Central timezone.

@darcy , @rfaramir , and @Marc_Keyman ,

After using Ukelele as a simpler alternative, I’m now back to Keyman. I’ve uninstalled and reinstalled with a restart about 4 times now. Unfortunately, it’s still grayed out. That said, I’ve noticed something…

If I remove keyman from the input source and add it back, the keyman program works as expected for a time. After about a minute or two, it will go back to being grayed out and become inaccessible. I repeated this process multiple times, and the result are the same each time. I’m able to access the keyboard as expected, but then the keyman input source becomes grayed out and the input source returns to my default keyboard.

I’ve checked the permissions and they currently allow keyman to access input monitoring. Are there other permissions that should be enabled?

Also, I can double click a .kmp file, and keyman will install the keyboard as expected, but I can’t actually select the keyboard when keyman is grayed out on the input source menu in the top right.

Hi @Rich_Meister,

I am still not sure what the issue is here. Can you advise which version of Keyman you are using, and which version of macOS? Note that @rfaramir is no longer on the team so you’ll need to coordinate with me. I am somewhat time poor currently but would like to get to the bottom of this problem, so am happy to setup a remote support session if we can find a workable timeslot.

Marc,

I have the latest version of Keyman offered on the website and the latest version of macOS as well.

Email or message me directly to setup a time to do a remote support session. I’m in EST/GMT -4 currently so it should be easier than when I’m overseas.

Regards,
Rich

Hi Rich,

Thank you for your time investigating this with me today. Sad that I wasn’t able to find an answer for you. I have written up the issue for further investigation on our bug tracker at https://github.com/keymanapp/keyman/issues/3170.