Aeneas not generating Synchronization files

I am trying to sync text with audio, but the file isn’t getting generated. Logs below:

/Users/cs/App\ Builder/Reading\ Apps/Phrases/com.chetansachdev.aeneastest/ ; exit;

*** Audio-Text Synchronization with aeneas ***

Version    : 
File Count : 1

*** B001 01 ***

Audio   : Chapter1124.mp3
Phrases : C01-01-B001-01-aeneas.txt
Output  : C01-01-B001-01-timing.txt
Head    : None
Tail    : None

+ null -m /Users/cs/dev/rab/aeneastest/Chapter1124.mp3 '/Users/cs/App Builder/Reading Apps/Phrases/com.chetansachdev.aeneastest/C01-01-B001-01-aeneas.txt' 'task_language=hi|is_text_type=parsed|os_task_file_format=tsv|task_adjust_boundary_algorithm=percent|task_adjust_boundary_percent_value=50' '/Users/cs/App Builder/Reading Apps/App Projects/aeneastest/aeneastest_data/timings/C01-01-B001-01-timing.txt' --skip-validator
/Users/cs/App Builder/Reading Apps/Phrases/com.chetansachdev.aeneastest/ line 28: null: command not found

Time elapsed: 00:00

Please find the generated timing files in the following folder:
/Users/cs/App Builder/Reading Apps/App Projects/aeneastest/aeneastest_data/timings

To test the synchronization before building an app, right-click on a row in the Audio Files table and select 'Export to HTML'.

To fine tune the timing files, right-click on a row in the Audio Files table and select 'Fine Tune Timings'.

Saving session...completed.

[Process completed]

I was using Hindi text and thought it could be an issue with text, so tried the text in Terminal and tested using espeak. It works fine from terminal. Any suggestions on what could be causing this?

Is there a webinar recording available to see how to use Aeneas features? Kindly help with the link.

Note: All the checks are successful.

It looks like your Reading App Builder is not seeing where Aeneas has been installed. Did you run the Aeneas installation while RAB was running? If so, please restart and see if it works.

Thanks for the response Richard.

I tried to verify “Check aeneas installation” and it can’t find the python now. On terminal, I am able to see that python is installed.

Check aeneas installation output

Last login: Mon Feb 14 16:39:17 on ttys000
/var/folders/77/qstzpyd15h782vcmx3zzhy7c0000gn/T/ ; exit;
/Users/cs/.zprofile:fg:9: no current job
/Users/cs/.zprofile:10: command not found: rbrew:
/Users/cs/.zprofile:fg:12: no current job
Example usage:
  brew search TEXT|/REGEX/
  brew info [FORMULA|CASK...]
  brew install FORMULA|CASK...
  brew update
  brew upgrade [FORMULA|CASK...]
  brew uninstall FORMULA|CASK...
  brew list [FORMULA|CASK...]

  brew config
  brew doctor
  brew install --verbose --debug FORMULA|CASK

  brew create URL [--no-fetch]
  brew edit [FORMULA|CASK...]

Further help:
  brew commands
  brew help [COMMAND]
  man brew

❯ /var/folders/77/qstzpyd15h782vcmx3zzhy7c0000gn/T/ ; exit;

Checking aeneas installation...

Python not found

Saving session...completed.

[Process completed]

python version in terminal

❯ python --version
Python 3.9.10

Any suggestion on how I can configure aeneas to detect the python version?

I tried to install aeneas-mac-setup- again and all the checks pass during the installation. But when I try to check this from RAB, python isn’t found. But python is installed globally and I can verify by checking the python --version.

What could be the issue?

I am using Apple M1, macOS Monterey 12.1.

We recently released an Aeneas installer that has Python 3 support. Did you use the Python 3 version? If not then get that and try that. The date on the Python 3 release is old. But up until last week we only had Aeneas for Python 2…7, now we have both versions.

Apple has dropped Python 2.7 from recent OS releases.

Oh we don’t have the Python 3 versions on RAB site yet. Go to the SAB site.

I have installed the Python 3 version from SAB site and tried it. Still its the same issue. During the installation all the checks are successful, but when I run “Check aeneas installation”, I am getting an error that python isn’t found.

Kindly advice how to fix it. Let me know if we can connect on zoom or hangout to troubleshoot this.

I have tested the pip and python versions, please confirm if these are the right ones.

I found that in Apple M1, python 3.7.4 need to be run using Rossetta for x86 compatibility, is it is trying to use a bundled version it may not run.

I tried to find in the Application, how its checking the aeneas but couldn’t figure out the github repo for RAB. Could someone help me with the link to RAB’s github repo link.

Found this link on stackoverflow, it could be the way its triggering to check the python.

Kindly advice how to proceed.

I have tried different ways, but couldn’t resolve the issue with “Python not found”. Kindly suggest how to fix this?

RAB is not in a Public Github repository.
The aeneas-installer is public: GitHub - sillsdev/aeneas-installer

If the installer is saying everything is there. You may be able to manually create Phrases files in RAB, from the Audio Syncronization tab and choose the Tab-delimited phrase files (.phrases).
Then use the installed Aeneas suite to run from the terminal.

I’ll write this up for the Developers to look at. I could not help you any more by Zoom.

I don’t believe they have an M1 machine to test on yet. But they have requested one.

Here is the content of a successful sync for one chapter done in SAB.

main() {
{ set +x; } 2>/dev/null
STARTTIME=$(date +%s)
echo ""
echo "*** Audio-Text Synchronization with aeneas ***"

echo ""
echo "Version    : 1.7.3"
echo "File Count : 1"


echo ""
echo "*** MAT 01 ***"
echo ""

echo "Audio   : B01___01_Matthew_____ENGWEBN2DA.mp3"
echo "Phrases : C01-01-MAT-01-aeneas.txt"
echo "Output  : C01-01-MAT-01-timing.txt"
echo "Head    : Detect between 6.00 and 12.00 seconds"
echo "Tail    : None"
echo ""

set -x
python -m "/Users/ianm/Documents/English_eng_WEB_NT_Drama/B01___01_Matthew_____ENGWEBN2DA.mp3" "/Users/ianm/App Builder/Scripture Apps/Phrases/org.test.scr.eng.web.nt/C01-01-MAT-01-aeneas.txt" "task_language=eo|is_text_type=parsed|os_task_file_format=tsv|os_task_file_head_tail_format=hidden|is_audio_file_detect_head_min=6.00|is_audio_file_detect_head_max=12.00|task_adjust_boundary_algorithm=percent|task_adjust_boundary_percent_value=50" "/Users/ianm/App Builder/Scripture Apps/App Projects/WEB NT/WEB NT_data/timings/C01-01-MAT-01-timing.txt" --skip-validator
{ set +x; } 2>/dev/null

echo ""

CURRENTTIME=$(date +%s)
MM=$(($DIFF / 60))
SS=$(($DIFF % 60))
printf "Time elapsed: %02d:%02d
" $MM $SS

echo ""
echo "----------"
echo "Please find the generated timing files in the following folder:"
echo "/Users/ianm/App Builder/Scripture Apps/App Projects/WEB NT/WEB NT_data/timings"
echo ""
echo "To test the synchronization before building an app, right-click on a row in the Audio Files table and select 'Export to HTML'."
echo ""
echo "To fine tune the timing files, right-click on a row in the Audio Files table and select 'Fine Tune Timings'."
echo ""


That may help to run it manually.

1 Like