Aeneas check failing in Apple M1 Macbook Air

System configuration:
macOS Monterey version 12.1
MacBook Air (M1, 2020)
Chipset Apple M1

I have successfully installed “Reading App Builder 9.2.2”, “aeneas-mac-setup-1.7.3.dmg” and “zulu8.60.0.21-ca-fx-jdk8.0.322-macosx_aarch64.dmg”.
I am able to launch Reading App Builder and installed Android SDK. Following the Installation instruction, I tried to check “check aeneas installation” and it throws an exception window and check fails.

❯ /var/folders/77/qstzpyd15h782vcmx3zzhy7c0000gn/T/ ; exit;

Checking aeneas installation...

Aeneas Version: 1.7.3

Python 2.7.18
[INFO] ffprobe        OK
[INFO] ffmpeg         OK
/var/folders/77/qstzpyd15h782vcmx3zzhy7c0000gn/T/ line 2: 24712 Illegal instruction: 4  python -m aeneas.diagnostics

Saving session...completed.

[Process completed]

Following same instruction on intel based mac, all the steps worked as expected and “aeneas check” is successful.
Attaching the logs for someone to check and suggest how to make it work in Apple M1.

Yes I have seen this before on another Mac M1.

I have written it up. It may take a bit to track down the issues. Remember that these tools are third party, so not fully in our developers control.

Re download Aeneas but choose the Mac version with Python 3. It works with Monteray.

Thanks for the response Ian.
I looked at the download page on Download - Reading App Builder and don’t find an option to see which version is using Python 3. Could you please help with the right link.

I uninstalled the existing version using uninstall scripts and then downloaded the latest build from GitHub - sillsdev/aeneas-installer . It works fine and all checks are passing in Apple M1 Macbook.

Thank you

Great news. Thanks for the Update

You may need to refresh the browser page if you don’t see the Python 3 version.